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Purpose 

Crystal Oscillator is one of the class of oscillators which brings its own challenges to 
simulate. One of the key challenges it brings to simulate is a long startup time. 

The purpose of this document is to make suggestions regarding the best practices for 
simulating Crystal Oscillators. A database composed of the circuits needed to 
reproduce these results is provided separately. 

This RAK demonstrates a method to do Crystal Oscillator simulation using SpectreRF 
Analyses. Initially, a transient analysis is done and then hb/hbnoise analysis is used to 
determine the oscillation frequency and the phase noise of the oscillator. 

Audience 

This document is intended for Analog/RF engineers involved in designing Crystal 
Oscillators. 

Terms 

RF  Radio Frequency 

RAK  Rapid Adoption Kit 

HB  Harmonic Balance 

PDK  Process Design Kit 

ADE  Analog Design Environment 
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Introduction 

The basic strategy is to simulate the Crystal Oscillator using harmonic balance (hb) 
analysis followed by hbnoise analysis to measure the PM (Phase-Modulated) 
component of the oscillator phase noise. 

First, an estimate of the number of harmonics that will be needed for the hb analysis is 
determined. This is done using the transient analysis, and it uses a simulation capability 
introduced from MMSIM 16.1_ISR9. This capability allows estimating the amplitude of 
the oscillations at the start of the transient analysis. In this transient run, the largest slew 
rate of the signals in the circuit is determined. From this information, 0 to 100% risetime 
is determined, and an estimate of the number of harmonics needed is obtained by 
dividing the period from the risetime. 

Once this estimate is made, a harmonic balance (hb) simulation is set up followed by an 
hbnoise analysis to measure the phase noise of the oscillator. 

After that, the Q of the resonator is varied to see what happens to the phase noise 
produced by the system. The Q is varied by changing the inductor and capacitor values 
in the resonator while maintaining the resonant frequency. 
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Setup and Files Required To Perform Simulation 
There is a single zipped tar file xtal_example_database.tar.gz that is composed 

of an IC61 library, a cds.lib file, and a directory named as share in which you need 

to download the gpdk180 PDK.  

1. Extract this zipped tar file in a writable directory using: 

unix%> tar zxvf  xtal_example_database.tar.gz 

unix%> cd xtal_example_database 

2. Then, step into the share directory. 

unix%> cd share 

3. You can download gpdk180_v3.3 in the share directory from: 

http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:DocumentViewer;sr
c=wp;q=ProductInformation/GPDK/GPDK.htm  

This library is assumed to be located in the share directory (as mentioned above). 

Below is what you should see inside the share directory. 

Figure 1 – Linux Terminal View showing the details of gpdk180_v3.3b PDK 

 

http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:DocumentViewer;src=wp;q=ProductInformation/GPDK/GPDK.htm
http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:DocumentViewer;src=wp;q=ProductInformation/GPDK/GPDK.htm
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4. Create a link to gpdk180_v3.3 by gpdk180 using the following command: 

unix%> ln -s gpdk180_v3.3 gpdk180 

5. Move one level up from the share directory to the xtal_example_database 

directory. 

unix%> cd .. 

6. Then, verify that you have a simulator version that supports estimation of the 
oscillator amplitude by typing the following command: 

unix%> spectre –h tran 
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7. Look at the output and verify that the linearic and oscfreq options are 

present in the Initial-condition parameters section as shown below. These 
options will be used later to estimate the amplitude of oscillations at the start of 
the transient analysis. If your simulator release does not have these options, you 
will need to start the oscillator from scratch and run the simulation long enough to 
approach the steady-state amplitude. Alternatively, you might choose to start with 
an estimate of how many harmonics might be required for the harmonic balance 
simulation. 

Figure 2 - spectre -h tran - Transient Analysis Parameters 

 



SPECTRE18.1: Crystal Oscillator Simulation Using SpectreRF: RAK 

Learn more at Cadence Support Portal - https://support.cadence.com 

© 2019 Cadence Design Systems, Inc. All rights reserved worldwide. Page 9 

 

Simulating Crystal Oscillator 

Estimating the Number of Harmonics Required Using Transient 
Analysis 

8. Launch Virtuoso. 

unix%> virtuoso & 

9. Open the Library Manager by going to Tools > Library Manager in the CIW 
window. 

Figure 3 – Library Manager window 
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10. From the Library Manager, open the schematic view by going to xtal_example > 
10M_Crystal_Oscillator > schematic as shown in Fig 4. 

Figure 4 - Opening schematic view of 10M_Crystal_Oscillator cell from xtal_example library 
using Library Manager 
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The 10M_Crystal_Oscillator circuit schematic appears as shown in Fig 5. 

Figure 5 - Schematic of 10M_Crystal_Oscillator cell 

 

The background of all the schematics in this document have been changed to white. 
This is done so that the schematic will be visible if this document is printed. 

You can also refer to Article How to change display background color of Schematic and 
Layout windows from black to white to get more details on how to change the schematic 
background to white. 

  

https://support.cadence.com/apex/ArticleAttachmentPortal?id=a1Od0000000nVJNEA2
https://support.cadence.com/apex/ArticleAttachmentPortal?id=a1Od0000000nVJNEA2
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11. Select the crystal symbol at the bottom of the schematic, click RMB, and 
descend-read into the underlying schematic in a new tab as shown in Fig 6. The 
schematic which appears, as shown in Fig 7, is representative of a commercially 
available 10MHz crystal, and is not representative of any specific manufacturer. 

Figure 6 - Selecting the crystal symbol in the schematic of 10M_Crystal_Oscillator cell 
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Figure 7 – 10M Crystal Oscillator schematic (representative only) 

 

12. Click the 10M_Crystal_Oscillator tab to get back to the top-level schematic. 

13. Go to Launch > ADE Explorer in the schematic window. 

Figure 8- Open ADE Explorer from the schematic window 
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14. In the Launch ADE Explorer dialog box, select “Open Existing View” if not 
already selected and click OK. 

Figure 9 - Open an existing maestro view in ADE Explorer 

 

15. In the Open ADE Explorer View window, select the maestro_Tran_Setup view 
from the View drop-down list and click OK to close the form. 

Figure 10 - Open maestro_Tran_Setup view from the Open ADE Explorer View form 

 

  



SPECTRE18.1: Crystal Oscillator Simulation Using SpectreRF: RAK 

Learn more at Cadence Support Portal - https://support.cadence.com 

© 2019 Cadence Design Systems, Inc. All rights reserved worldwide. Page 15 

 

16. An ADE Explorer window with the maestro_Tran_Setup view gets opened in a 
new tab. 

Figure 11 - Opening maestro_Tran_Setup view in ADE Explorer 
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17. In the ADE Explorer window, open the Simulator Options form (Simulation > 
Options > Analog) and note that reltol and vabstol have been changed from 
the default values. This is suggested to make the simulation more accurate than 
the default settings. Once reviewed, click OK to close the form. 

Figure 12 – Transient analysis - Simulator Options form 
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18. In the ADE Explorer window, double-click on the tran analysis line in the 
Analyses section of the Setup Assistant. This will open the Choosing Analyses 
form with tran analysis settings. 

The frequency of the example crystal is 10MHz. The stop time is set to about 20 
periods of the oscillator frequency. 

Figure 13 - Choosing Analyses form - Setting up transient analysis 

 

19. Click the Options button at the bottom of the form. 

20. In the Transient Options form which gets opened, click the Algorithm tab. The 
window might need to be resized. 
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You will see that the Calculate ic automatically option is set to yes. The oscillator 
frequency for this example is 10MHz; so, the Estimated frequency option is set to 
10MHz.  

You will also see that the method is set to traponly and the relref is set to alllocal. 

Figure 14 - Transient analysis – Transient Options form – Setting method and relref 
parameters 
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Traponly is suggested for the integration method because this method does not 
numerically emphasize or numerically damp the oscillations in the circuit. Alllocal is 
suggested because there are large amplitude signals in the High Q resonator. 

Note that in the transient analysis, each timepoint is an iterated solution. The iterations 
stop when the convergence criteria are met. The convergence criteria for voltages is as 
follows: 

• reltol * largest voltage on the net up to the current time + vabstol (when 
alllocal is set) 

• reltol * largest voltage anywhere in the circuit up to the current time + vabstol 

(when the default sigglobal selection is used) 

Because sigglobal takes the largest voltage in the circuit, the accuracy on the low-
voltage nets would be seriously degraded because of the large amplitude signals in the 
resonator. 
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For reference only, shown below is a plot of the net called resonator in the crystal 
motional equivalent circuit. Normal voltages at this net are in the 500V to 2KV peak 
range. You can verify this after the transient simulation runs. 

Figure 15 - Transient analysis response of resonator net signal 

 

The waveform starts at a peak in the resonator. This is due to the estimate of the 
oscillating condition at time zero. 

Note: The background of the plot window is changed to white by adding the following 
line to the .cdsinit file: 

envSetVal(“viva.graphFrame” “background” ‘string “white”)  

21. Click OK to close the Transient Options form and the Choosing Analyses 

form. Then, run the simulation by clicking  in ADE Explorer. At the end of the 
simulation, the output signals of the two gates should plot.  
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22. After splitting the strips, the plot appears as shown in Fig 16. 

Figure 16 – Plot of osc_out net voltage and buf_out net voltage signal after transient analysis 
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23. Change the scale of y-axis of buf_out signal to -0.5V – 3.5V.  

Figure 17 - Changing Y-axis limits 
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The plot should look as shown in Fig 18. 

Figure 18 - Plot of osc_out net voltage and buf_out net voltage signal after manual scaling of 
y-axis of buf_out signal plot 
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24. Now, zoom in near the end and determine the largest slew rates for both signals. 

Figure 19 – Determining largest SlewRate of osc_out and buf_out net voltage signals 

 

In the above waveforms, both the rising and falling edges were analyzed. The edge with 
the largest slew rate is shown. The slew rate is displayed as the bottom number in the 
delta readouts, as highlighted above. 

25. To position a marker, point your cursor near the location where you want the 
marker and type m. To get a delta marker, select a marker on the screen, then 
move to the next place you want to measure, and type Shift+d. Both marker 
locations can be moved holding the left mouse button down over a marker and 
moving the cursor. 

26. Determine the 0% to 100% rise/fall time for both signals. For the osc_out signal, 

it is 3.3/334.85e6, and for the buf_out signal, it is 3.3/2.78e9.  

(9.86e-9 and 1.19e-9, respectively) 
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27. Determine the estimated number of harmonics by dividing the period by the 
risetime.  

For the osc_out signal: 1e-7/9.86e-9 = 10.14. Round up to 11.  

For the buf_out signal: 1e-7/1.19e-9 = 84.  

28. Close the ViVA XL Waveform window by going to File > Close All Windows in 
that window. 

29. Close the ADE Explorer window by going to the maestro_Tran_Setup tab and 
clicking Session > Quit in that window. Click ‘Yes’ when asked to save the ADE 

Explorer setup. 

Setting Up Harmonic Balance Simulation 

30. Go to the 10M_Crystal_Oscillator schematic tab, and then click Launch > ADE 
Explorer. 

Figure 20 - Open ADE Explorer from the schematic window 

 

31. In the Launch ADE Explorer dialog box, select “Open Existing View” if not 
already selected and click OK. 

Figure 21 - Open an existing maestro view in ADE Explorer 
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32. In the Open ADE Explorer View window, select the 
maestro_Oscillator_Normal_Setup view and click OK to close the form. 

Figure 22 - Open maestro_Oscillator_Normal_Setup view from the Open ADE Explorer View 
form 
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33. An ADE Explorer window with the maestro_Oscillator_Normal_Setup view 
gets opened in a new tab. 

Figure 23 - maestro_Oscillator_Normal_Setup view in ADE Explorer in new tab 
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34. In the ADE Explorer window, double-click on the hb analysis line in the Analyses 
section of the Setup Assistant. This will open the Choosing Analyses form with 
hb analysis setup. 

Figure 24 - Choosing Analyses form - Setting up of harmonic balance (hb) analysis 
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Analyzing the Harmonic Balance Analysis Settings 

35.  Analyze the settings of the hb analysis. 

a. Run transient is set to No. This causes hb to start without running a tstab 
transient analysis. 

b. Fundamental Frequency is set to the oscillator frequency. 

c. The Number of Harmonics field is set to 11, which we calculated for the 
osc_out net. If the transient analysis from the preceding section is not 

available, start with an estimate of the number of harmonics that might be 

needed. The number of harmonics needed will be verified shortly. 

d. Oversample Factor is set to 1. When the estimation procedure is used, 
oversample can usually be set to 1. 

e. Conservative accuracy is always recommended for any oscillator. 

f. The oscillator node is not critical. It should have a signal on that net. 

g. It is suggested that you select the Calculate initial conditions (ic) 
automatically option for any Crystal Oscillator. In earlier releases, this 
was the Calculate oscillator initial conditions option, which had two 
settings: Default and Linear. The Linear selection is the equivalent to the 
new setting. 

This option causes Spectre to run a variation of the stability analysis after 
running the DC solution. It estimates the amplitudes and phases on all the 
nets for the first harmonic. When Run transient is set to “no”, this 
estimate is used as the starting point of the harmonic balance analysis for 
the first harmonic and the DC solution is used for the DC harmonic. The 
harmonic balance algorithm goes on to solve for the specified number of 
harmonics of the nonlinear circuit. In many cases, this is a good enough 
starting point that allows the harmonic balance analysis to converge. 
Because this mode completely bypasses any transient analysis in the 
tstab interval, it runs quickly as well. 
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Setting Up Harmonic Balance Analysis Options 

36. Click the Options button at the bottom of the hb Choosing Analyses form. 

37. Click the Convergence tab.  

38. Although Spectre has an algorithm for picking the pinnode automatically, for 
Crystal Oscillators, it is usually better to specify the pinnode yourself. The best 
choice is the net that is the junction between the inductor and the capacitor of the 
motional equivalent circuit as shown below. 

Figure 25 – Setting up pinnode option in the Convergence tab of Harmonic Balance Options 
form by selecting resonator net between the inductor and the capacitor of the motional 

equivalent circuit of Crystal Oscillator 
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39. The tab at the top of the crystal motional equivalent circuit displays the instance 
name of the crystal symbol. Specify the hierarchical path to the resonator net in 
the pinnode option. In this case, the setting for the pinnode would be 
I2.resonator.  

This is shown in the options form below. 

Figure 26 - Harmonic Balance Options 

 

If convergence is not attained in the hb analysis, consider raising maxperiods to 
the 300 to 500 range. The default allows 100 iterations before reporting non-
convergence. High Q circuits may require more iterations in order to allow 

convergence to be attained. 

Take the defaults for all the other options. 

40. Click OK in the Harmonic Balance Options form. 
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Setting Up the Harmonic Balance Noise (hbnoise) Analysis 

41. In the Choosing Analyses form, select hbnoise. 

Figure 27 - Choosing Analyses form - Setting up of hbnoise analysis 

 



SPECTRE18.1: Crystal Oscillator Simulation Using SpectreRF: RAK 

Learn more at Cadence Support Portal - https://support.cadence.com 

© 2019 Cadence Design Systems, Inc. All rights reserved worldwide. Page 33 

 

Analyzing the Harmonic Balance Noise Analysis Settings 

The default Sweeptype is relative. Since a log sweep just above the output frequency 
is desired, the relative harmonic number is used to specify which harmonic is the output 
harmonic. Most Crystal Oscillators use the first harmonic. 

42. In relative sweeptype, the sweep range specifies frequency offsets above the 
output frequency to be measured. Set an appropriate range for your circuit. 

43. Logarithmic is usually desired. Generally, it is better to select Logarithmic 
manually, and then specify three to five points per decade, than it is to use the 
default of Automatic. Automatic will always run 100 total noise points, which is 

usually more than required. Specifying a log sweep manually usually saves 
simulation time. 

44. Leave the Maximum sideband field blank. This causes noise folding near all the 
harmonics in the hb large-signal analysis to be included in the hbnoise analysis. 

45. Usually, an oscillator has an output net in the circuit; so, the Output value should 
normally be set to voltage. If the output is a current, add an iprobe in series with 
the output of the oscillator in the schematic and set the Output selection to 
Probe. In that case, set the instance name of the iprobe in the Probe field. 

46. Use the Select button to the right of the Positive Output Node field, and then 
select the net in the schematic for the noise output. This circuit is single-ended. 
In any of the fields where there is a negative net in any analysis in SpectreRF, if 
the Negative Output Node field is left blank, the global ground net will be used 
as the reference net. 

47. Generally, the PM component of phase noise is desired. To make this 
measurement in hbnoise, select timeaverage for the Noise Type field and then, 
as Contribution Type, either select PM or ALL(AM,PM,USB,LSB). 

48. Click OK to close the Choosing Analyses form. 

49. Click on the  icon in the ADE Explorer window and run the analysis. 

50. Once the analysis is finished, check the Spectre output window (spectre.out 

file).  

There are several things to check in the Spectre output window. 

a. Just below the circuit inventory, the pinnode is displayed. When you run 
the circuit for the first time, make sure that the schematic net is displayed 
and there are no warnings indicating that the net does not exist. 
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b. Just below that is a message that the linear initial condition is being 
calculated. The warning messages below the Linear IC statement can 
always be ignored. 

c. The first time the simulation runs, or any time you get non-convergence, 
check that the frequency determined by the Linear IC is correct for your 
circuit.  
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d. If the Linear IC fails, try a different pinnode inside the resonator, or change 
the frequency estimate in the hb Choosing Analyses form by about 10%. 

Figure 28 – Analyzing Spectre output log file (spectre.out) – hb analysis output 
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e. Then, hb runs and reports progress. 

Figure 29 - Analyzing Spectre output log file (spectre.out) – hb analysis output 

 

f. For the last several iterations, the Delta Norm and the Resd Norm should 
be steadily decreasing, and the delta frequency should be some small 
fraction of 1 Hz. 

g. When the Noise Type is set to timeaverage and ALL, hbnoise runs 
frequencies above and below the output harmonic; so, you will see 
positive and negative frequencies in the hbnoise output file. 
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51. When the analysis completes, open the Direct Plot Form using one of the 
following two methods:  

a. From the 10M_Crystal_Oscillator schematic tab, select the red arrow to 

the right of the Direct Plot icon ( ) and then select Main Form.  

b. From the maestro_Oscillator_Normal_Setup tab in the ADE Explorer 
window, select Results > Direct Plot > Main Form. The Direct Plot 
Form is as shown below. 

Figure 30 - Direct Plot Form - Plotting hb analysis results 
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52. If you want to have the selected curves plot automatically after you make 
changes to your circuit and re-simulate, click the Add To Outputs checkbox at 
the bottom of the form. 

Figure 31 - Enable 'Add to Outputs' checkbox 

 

53. To plot the hb results, select hb at the top of the form (if not already selected). 
Many formats are possible. In this example, power based on the voltage on a net 
with an assumed load resistor is plotted. Set up the Direct Plot Form as shown 
in Fig 32. 

Figure 32 - Plot power at osc_out net 
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54. Select the osc_out net from the schematic. The result is as shown in Fig 33. 

Figure 33 - osc_out net voltage output spectrum from hb analysis 
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55. One way to determine the frequency more exactly is to send the spectral results 
to a table, and then set more digits for the frequency. To do this, perform the 
following steps: 

a. Select the trace legend. The legend will highlight.  

b. Right-click and release. Move to Send To > Table > New Window. 

Figure 34 - hb analysis results – Send To a Table in New Window 
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The table window appears as shown in Fig 35. 

Figure 35 – osc_out voltage spectrum output in ViVA table 
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56. Select the frequency column. It will highlight as shown in Fig 36. 

Figure 36 - Selecting the frequency column in Viva table 

 

57. In the table window, select View > Format. In the Format Attributes window, 
type 14 in the Significant Digits field. 

Figure 37 – Setting Format Attributes – Significant Digits is set to 14 
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58. Select OK. The frequency field updates with 14 digits as shown in Fig 38. 

Figure 38 – Frequency column showing 14 significant digits in ViVA table 

 

The frequency of the oscillator is shown with more resolution. 

59. Close the table window and the waveform window.  

There is a second method coming up shortly. 

60. To plot the PM component of phase noise, select hbnoise results. 
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61. Select the PM component as Noise Type and then dBc as Modifier. Also, set the 
Noise convention as DSB. 

Figure 39 - Direct Plot Form - Plotting hbnoise results 
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62. Click Plot.  

The result is shown in Fig 40. 

Figure 40 - Plotting PM noise of oscillator 

 

63. The phase noise curve has a vertical marker placed at 1Hz. To place a vertical 
marker, move your mouse cursor near the desired frequency on the trace and 
type v. To exactly place the marker, select it and then the frequency at the lower 
left of the marker becomes editable.  

The readout to the right of the legend is the value at the vertical marker. This is 
highlighted in the red box above. 

64. Click OK to close the Direct Plot Form. 
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Verifying If the Harmonics Set Are Enough 

Check to see if you have enough harmonics. Many Crystal Oscillators operate at 
frequencies much lower than the Ft of the devices. There is the potential of noise at 
higher frequencies folding down to the output frequency; so, checking to see if there are 
enough harmonics is strongly suggested. 

65. Go to the maestro_Oscillator_Normal_Setup tab in the ADE Explorer window 
and double-click on the hb analysis line in the Analyses section of the Setup 
Assistant. Increase the number of harmonics by about double. In this example, 
the number of harmonics was changed to 21. 

Figure 41 - Choosing Analyses form - Setting up hb analysis with number of harmonics set to 
21 
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66. Click OK in the Choosing Analyses form. 

67. To get more digits in the Spectre output window, open the Simulator Options 
form by going to Simulation > Options > Analog. Then, select the Annotation 
tab. Type 14 in the digits field (if not set already). 

Figure 42 - hb analysis - Simulator Options 

 

68. Click OK to close the Simulator Options form. 
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69. To plot the new result over the existing result, set the Plotting Mode in the ADE 
Explorer window to Append mode. Since the focus is on noise, the hb large-
signal result has been deselected in the outputs section. 

Figure 43 - ADE Explorer window when the Plotting mode is set to Append and hb large-signal 
results deselected in the outputs section 
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70. Run the simulation by clicking the  icon and compare the noise results. 

Figure 44 - PM noise plot of Crystal Oscillator 

 

The noise result at 1Hz changed considerably. Also, the noise above about 100Hz is 
visibly different. An additional vertical marker was placed at 3 KHz. The readout to the 
right of the legend will read the result of the selected vertical marker. 

  



SPECTRE18.1: Crystal Oscillator Simulation Using SpectreRF: RAK 

Learn more at Cadence Support Portal - https://support.cadence.com 

© 2019 Cadence Design Systems, Inc. All rights reserved worldwide. Page 50 

 

71. Note the frequency in the Spectre output window. Go to the bottom of the hb 
output and read the frequency. This is highlighted below. 

Figure 45 - Analyzing Spectre output log file (spectre.out) – hb analysis simulation output 

 

Note that the fundamental frequency is around 10MHz, and the delta f on the last 
iteration is 5.03e-05 Hz. This gives an actual resolution of 5.03e-05/1e7 or 5.03e-12. 
This will change with different numbers of harmonics because the solution is slightly 
different. The frequency will also be very slightly different. 
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72. Now, roughly double the number of harmonics to 41 and rerun the simulation. An 
odd number of harmonics is chosen because, in this case, the odd harmonics are 
emphasized in the large-signal result.  

73. When the noise result plots, select the MarkerTable Workspace in the ViVA 
window. This shows the values of both the markers at the bottom of the 
waveform tool. 

Figure 46 – PM noise plot of Crystal Oscillator – MarkerTable Workspace in ViVA window 
(when number of harmonics is set to 41 in hb analysis) 
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74. The results for both markers are still changing; so, double the harmonics to 81 
and rerun the simulation. 

Figure 47 - PM noise plot of Crystal Oscillator – MarkerTable Workspace in ViVA window 
(when number of harmonics is set to 81 in hb analysis) 
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75. The results are still changing; so, rerun the simulation with 161 harmonics. 

Figure 48 - PM noise plot of Crystal Oscillator – MarkerTable Workspace in ViVA window 
(when number of harmonics is set to 161 in hb analysis) 

 

76. The result is stable at 81 and 161 harmonics; so, 81 harmonics are enough. If 
desired, you can try 321 harmonics; you will see that the result is almost the 
same and the runtime is much longer. 

77. Close the waveform tool when you are satisfied that 81 harmonics are enough. 
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Investigating the Effect of Running the Transient in the tstab Interval 

Using the estimate of the oscillator frequency as the starting point of the harmonic 
balance simulation without running tstab is a viable strategy for many oscillators. 
However, for nonlinear oscillators, the starting point provided by the initial condition 
calculation is not close enough to allow convergence. In this case, try setting a small 
number of cycles in tstab, and running again. Running that small number of cycles and 
using the last cycle’s fft as the starting point for the harmonic balance iterations can 
improve the convergence of the oscillator. Sometimes, this also saves the overall 
simulation time by reducing the number of frequency domain iterations in harmonic 
balance. This is not a given. Some oscillators will only converge when tstab is specified, 

and some oscillators will only converge when tstab is not run. This section will 
investigate this strategy. 
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78. In the ADE Explorer window, double-click on the hb analysis line in the Analyses 
section of the Setup Assistant, and set the Number of Harmonics to 81. 

Figure 49 - Choosing Analyses form - Setting up hb analysis with maxharms set to 81 
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79. Run the simulation. The noise plots. 

Figure 50 - PM noise plot of Crystal Oscillator (when Number of Harmonics is set to 81) 

 

  



SPECTRE18.1: Crystal Oscillator Simulation Using SpectreRF: RAK 

Learn more at Cadence Support Portal - https://support.cadence.com 

© 2019 Cadence Design Systems, Inc. All rights reserved worldwide. Page 57 

 

80. Note the Spectre output window. For the harmonic balance simulation, 51 
iterations are required, and the elapsed time is 3.73 seconds. 

Figure 51 - Analyzing Spectre output log file (spectre.out) – hb analysis simulation output 
(Observing the total number of iterations and the elapsed time for hb simulation) 
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81. In the ADE Explorer window, double-click on the hb analysis line in the Analyses 
section of the Setup Assistant. 

a. Now, set the Run transient choice to Yes. 

b. Uncheck the Detect Steady State checkbox. 

Since the crystal has a very high Q, steady-state will be detected almost 
immediately. Turn this off to make sure that the full time specified is 
actually run. This also eliminates the overhead of checking for steady-
state.  

c. The frequency of this oscillator is 10MHz. The period is 0.1usec. Set Stop 
Time (tstab) to 0.325u, which will run 3.25 cycles of the waveform in 
tstab. Remember from the transient analysis that the waveform starts at 
the peak voltage in the resonator. If an integer number of cycles are run in 
tstab, the period calculation will be hard because the waveform starts and 
ends at a peak. An additional quarter cycle has been added to tstab to 
allow the waveform to be roughly in the middle. This makes the period 
calculation from the waveform much more accurate and improves the 
chances of convergence because the frequency is more accurate for the 
first iteration of the hb analysis. 

d. Select yes in the checkbox to the right of Save Initial Transient Results 
(saveinit). 
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Your Choosing Analyses form should look like the one as shown below. 

Figure 52 - Choosing Analyses form - Setting up hb analysis with tstab (Enabling Transient-
Aided Options) 
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82. Click the Options button at the bottom of the form. This will bring up the 
Harmonic Balance Options form. 

83. In the Harmonic Balance Options form, perform the following actions: 

• Click the Accuracy tab. 

• Set the tstabmethod option to trap or traponly. Selecting traponly 
selects an electrically neutral numerical integration method. Do not use 
any other method as this would introduce numerical damping in the tstab 
transient that could cause the oscillations in the resonator to be smaller 
than the actual amplitude, which would reduce the chances of 

convergence. The euler option numerically damps especially heavily, and 
should never be used for any oscillator. 

Figure 53 - Harmonic Balance analysis - Harmonic Balance Options 

 

84. Click OK to close the Harmonic Balance Options form. 

85. Click OK to close the Choosing Analyses form. 
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86. Hit the Run button ( ) and run the analysis. 

The noise result is almost identical. 

Figure 54 - PM noise plot of Crystal Oscillator (with tstab set and when Number of Harmonics 
is set to 81) 
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87. Now, investigate the effect on the harmonic balance (hb) analysis in the Spectre 
output window. In this example, the number of iterations went from 51 to 13, and 
the elapsed time went from 3.73 seconds to 1.61 seconds. It is worth considering 
using this strategy because the convergence and runtime might improve. 

Figure 55 - Analyzing Spectre output log file (spectre.out) – hb analysis simulation output 
(Observing the total number of iterations and the elapsed time for hb simulation) 

 

88. Close the ViVA XL window. 
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89. Plot the Initial Transient Simulation results waveform. 

a. Open the Direct Plot Form and select tstab results by selecting tstab as 
Analysis. 

Figure 56 - Direct Plot Form – Plotting Initial Transient Simulation results 
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b. Select the resonator net from the schematic. The net is plotted below. 

Figure 57 – Plotting the Initial Transient Simulation (tstab) results of resonator net in ViVA 
window 

 

Why did Spectre actually run to 0.825usec when tstab was set to 0.325usec? First, 
tstab is run. This is 0.325usec. Then, one period of the frequency specified in the 
Choosing Analyses form is run. In this case, the frequency is set to 10M and that has 
a period of 0.1usec. Next, four periods of this frequency are run, and Spectre looks for a 
frequency divided output signal at all the nodes in the circuit. This adds the last 0.4usec 
to the waveform. In this example, there is no frequency division; so, Spectre then goes 

on to solve for one period of the oscillator waveform. 

90. Click OK to close the Direct Plot Form and close the ViVA XL window. 

91. Deselect the hb tstab portion result of the I2.resonator net in the outputs section. 
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Investigating the Effects of Resonator Q on the Oscillator Phase 
Noise 

92. From the Library Manager, open the schematic view of the following cells of the 
xtal_example library: 

• 10M_Crystal 

• 10M_Crystal_hi_Q 

• 10M_Crystal_lo_Q 

Figure 58 – Opening schematic view of 10M_Crystal, 10M_Crystal_hi_Q, and 
10M_Crystal_lo_Q cells of xtal_example library from Library Manager 
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The circuits differ in that the value of the resonator inductors and capacitors vary by 
factors of 10 and retain the same resonant frequency. 

Figure 59 – Schematic of 10M_Cystal Oscillator ( l=46.055m C=5.5f) 

 

Figure 60 - Schematic of 10M_Cystal_hi_Q Oscillator (l=460.055m C=550a) 
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Figure 61 - Schematic of 10M_Cystal_lo_Q Oscillator (l=4.6055m C=55f) 

 

93. After reviewing, close all the schematic windows (which are mentioned in Step 
92). 
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Plotting the PM Noise from the 10M_Crystal Schematic Cell 

94. From the ADE Explorer window, plot the PM (DSB) noise result by clicking the 

Plot Outputs icon ( ). This is the result with the medium Q crystal (that is, 
from 10M_Crystal Oscillator). 

Figure 62 - PM noise plot of medium Q crystal (that is, 10M_Cystal) Oscillator 
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Plotting the PM Noise from the 10M_Crystal_hi_Q Schematic Cell 

95. In the 10M_Crystal_Oscillator schematic window (consisting of the 10M_Crystal 
cell) which is already opened, select the crystal symbol and change the cell to 
10M_Crystal_hi_Q. 

96. Click OK to close the Edit Object Properties form. 

Figure 63 – Changing cell name to 10M_Crystal_hi_Q in Edit Object Properties form 
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97. In the schematic, select Check > Current Cellview. This will update the circuit to 
the new configuration without saving it to the disk. 

Figure 64 - Check Current Cellview 

 

98. Click on the Run Simulation icon ( ) from the 10M_Cystal_Oscillator 
schematic tab and rerun the simulation. (You can also rerun the simulation from 
the maestro_Oscillator_Normal_Setup tab). 

99. In the dialog box which appears, click on Update and Run as shown in Fig 65. 

Figure 65 - ADE Explorer Update and Run dialog box 
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The simulation finishes, and the noise result plots after the run completes. 

Figure 66 - PM noise plot of medium Q crystal and hi Q crystal (that is, 10M_Cystal and 
10M_Crystal_hi_Q) Oscillators 

 

The result is as expected. With a factor of 10 change in Q, the noise should change by 
about 20dB. 
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Plotting the PM Noise from the 10M_Crystal_lo_Q Schematic Cell 

100. In the schematic window of the 10M_Crystal cell, which is already opened, 
select the crystal symbol and change the cell to 10M_Crystal_lo_Q. 

101. Click OK to close the Edit Object Properties form. 

102. As shown above in Fig 64, in the schematic, select Check > Current 
Cellview. This will update the circuit to the new configuration without saving it to 
the disk. 

103. Click on the Run Simulation icon ( ) from the 
10M_Cystal_Oscillator schematic tab and rerun the simulation. (You can also 
rerun the simulation from the maestro_Oscillator_Normal_Setup tab). 

104. In the dialog box which appears, click on Update and Run as shown in 
Fig 67. 

Figure 67 - ADE Explorer Update and Run dialog box 
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The simulation finishes, and the noise result plots after the run completes. 

Figure 68 - PM noise plot of medium Q crystal, high Q crystal, and low Q crystal (that is, 
10M_Cystal, 10M_Crystal_hi_Q, and 10M_Crystal_lo_Q) Oscillators 

 

Now, the noise comes up almost 20dB. 

This concludes the Crystal Oscillator RAK. 
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105. Quit from the Virtuoso session. When asked to save the schematic view, 
select None and click OK. This will allow you to preserve the integrity of the 
original database. 

Figure 69 - Select None when asked to save the 10M_Crystal_Oscillator schematic view 

 

Summary 

The PM noise results of the Crystal Oscillator varies with the Q of the oscillator, as 
expected. The PM noise is higher for low Q crystal and reduces as the Q-factor of the 
crystal increases. 
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